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การวิเคราะหขอมูลดวยโปรแกรม SPSS 
 

 โปรแกรม SPSS for Windows (Statistical Package for Social Science) เปนโปรแกรม
สําเร็จรูปที่ใชสําหรับการวิเคราะหขอมูลทางสถิติ  สามารถสรางแฟมขอมูลและวิเคราะหขอมูลไดอยางมี
ประสิทธิภาพ  ซ่ึงผลลัพธสามารถแสดงออกมาในรูปของตาราง ขอความ  และแผนภูมิรูปตางๆ เชน 
แผนภูมิแทง  แผนภูมิเสน  และแผนภูมิวงกลม เปนตน 
 

การเริ่มตนเขาสูโปรแกรม SPSS 
 1. Double Click ที่ Icon ของ SPSS บนจอ Desktop รูป                             หรือเขาทาง 
Start > Programs > SPSS  ดังรูป 

ortcut to spsswin  

 

 

คลิก 1 ครั้ง เพื่อเขาสูโปรแกรม SPSS 

 

 2. เม่ือเขาสูโปรแกรม SPSS ไดแลวจะปรากฏหนาตางตอไปน้ี 

          

คลิก Type in data และคลกิ OK จะปรากฏ
หนาตาง SPSS Editor สําหรับปอนขอมูล 

หรือ Double Click ที่ชื่อแฟมขอมูลกรณีมี
แฟมขอมูลอยูแลว 
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สวนประกอบทั่วไปของโปรแกรม SPSS 
 หลังจากเขาสูโปรแกรมแลวจะขอแนะนําโครงสรางสวนประกอบโดยทั่วไปของโปรแกรม SPSS 
กอนที่จะดําเนินการวิเคราะหขอมูลตอไป  โดยจะนําเสนอคําอธิบายตามภาพประกอบดานลางนี้ 
 
 
 
 
 
 

 

4) Cell Editor = กําหนดคาตัวแปร 

3) Variables = กําหนดชื่อตัวแปร 

2) Menu Bar 

1) Title Bar 

6) Cases = ชุดของตัวแปร 

5) Cell = สําหรับกําหนดตวัแปร 

 
 
 
 

 
 
 

7) Status Bar = แสดงสถานะการทํางาน 

9) Variables view = สรางและแกไขโครงสรางตัวแปร 

8) View Bar 

10) Data view = เพ่ิมและแกไขขอมูลตวัแปร 
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มุมมอง (View Bar)  
 เปนการแบงสวนงานออกเปน 2 สวน ไดแก Variable View และ Data View  
 

 

Click 

 
แตละสวนมีหนาที่สําคัญดังน้ี 
 1. Variable View  เปนสวนที่ทําหนาทีส่รางหรือแกไขตวัแปร โดยตองกําหนดชื่อ ชนิด ความ
ยาว และความหมายของตัวแปร และใชในการตรวจสอบรายละเอียดของตัวแปร  ดังภาพ 
 
 
 
 
 
 

 
 
 
 
 
 

กําหนดชื่อตัวแปร 

กําหนดชนิดตัวแปร/ความกวางและทศนยิมของตัวแปร 

ความหมายของตัวแปร 

กําหนดคาของตัวแปร 
คาสูญหายใช 9 แทน กําหนดมาตรวัดตวัแปร 

การจัดขอมูลใหชิดซาย,ขวา,กลาง 

ความกวางสําหรับกรอกขอมูล 
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 2. Data View  เปนหนาจอสําหรับกรอกขอมูลตามตวัแปรที่กําหนดใน Variable view 
 

 
 
 

ชองสําหรับกรอกขอมูลตามตัวแปร 
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การสรางแฟมขอมูลจากแบบสอบถาม 
 
 การสรางแฟมขอมูลจากโปรแกรม SPSS น้ัน หลังจากเขาสูโปรแกรมแลวจะไดหนาจอ 
Untitled – SPSS Data Editor  ซ่ึงมี 2 tab  ที่อยูดานลางซายมือ  คือ  Variable View และ Data View  
ดังภาพ 

 

Click Variable View 

 
 หลังจากนั้นใหคลิกที่ Variable View ดานลางซายมือ เพ่ือเขาสูหนาจอสําหรับการสรางและ
กําหนดตัวแปร 
ขั้นตอนการสรางแฟมขอมูล 
 1. การกําหนดตัวแปร  ตองแปลงคําตอบจากขอคําถามในแบบสอบถามใหเปนตัวแปร  
โดยคําถาม 1 คําถามในแบบสอบถามสามารถสรางเปนตวัแปรไดอยางนอย 1 ตัว โดยเขาไปสรางตัว
แปรใน Variable View  
 
 

 

1 Row / 1 บรรทัด 
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  1.1 การตั้งชือ่ตัวแปร (name) 
   ในการตั้งชื่อตวัแปรผูใชควรกําหนดชื่อตัวแปร ใหสอดคลองกับความหมายของคาตัว
แปร เชน อายุ ควรตั้งชื่อเปน age เพศ ควรตั้งชื่อเปน sex หรือ gender สวนรายได ควรตั้งชื่อเปน 
income เปนตน 
  การตั้งชื่อตวัแปรในโปรแกรม SPSS มีขอจํากัดดังน้ี 

1) ความยาวของชื่อตองไมเกิด 8 ตัวอักษร 
  2) ชื่อตัวแปรตองขึ้นตนดวยตวัอักษรเทานัน้สวนตวัอ่ืนๆ จะเปนตัวเลขหรือสัญลกัษณ
พิเศษก็ได เชน &,©,δ, หรือ β ก็ได 
  3) ตัวแปรตองไมจบหรือลงทายดวยจุด (.) และหามใชสญัลักษณ !,?,‘ และ ∗ ในการตั้ง
ชื่อตัวแปร  
  4) ชื่อตัวแปรในแฟมขอมูลเดียวกันตองไมซํ้ากัน และการใชตวัอักษรใหญหรือเล็กถอืวา
เปนตวัแปรตวัเดียวกัน  เชน  Sex,  SEX,  sex 
  5) หามใชคําตอไปน้ีเปนชื่อตวัแปร  ALL  NE  EQ  TO  LE  LT  BY  OR  GT  AND  
GE  WITH   
  1.2 ชนิดของตวัแปร 
   หลังจากตั้งชือ่ตัวแปรแลวใหคลิกที่ column ของ type จะปรากฏดังภาพ 
 

 

Click ที่ Numeric จะ
ปรากฏ Variable Type 

ดังภาพดานลาง 

 

 

   

เลือกความกวาง
และทศนิยม 
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 ในหนาจอ Variable Type จะแบงตัวแปรออกเปน 8 ชนิด ดังน้ี 
 1) Numeric  เปนตัวแปรชนิดที่เปนตวัเลขทั้งที่มีคาเปนบวกและลบ 
 2) Comma เปนตวัแปรชนิดที่เปนทั้งตวัเลข จุดทศนยิม  และมีเครื่องหมาย Commaคั่น 
 3) Dot  เปนตัวแปรที่รวมทั้งตวัเลข มี Comma คั่น และใชเครื่องหมายจุด 
 4) Scientific Notation เปนตัวแปรที่มีคาเปนตัวเลข และสัญลักษณทางวิทยาศาสตร 
 5) Date  เปนตัวแปรชนิดที่เปนวันที่ ขอมูลจะอยูในรูปของวันเดือนป 
 6) Dollar เปนตวัแปรที่เปนชนิดตัวเลขและหมายถงึตัวเงินที่มีเครื่องหมาย $ มีจุด และ
เครื่องหมาย Comma คั่น 
 7) Custom  แบงเปน 5 รูปดวยกัน คือ CCA, CCB, CCC, CCD และ CCE  
 8) String  เปนตวัแปรทีมี่คาเปนตวัอักษร ตัวเลข หรือเครื่องหมายตางๆ ได เม่ือเลือกชนิด 
String จะตองกําหนดความกวาง 
  1.3 Width (การกําหนดขนาดของตัวแปร) เปนการกําหนดขนาดความกวางของตวัแปร
หรือจํานวนหลักของตวัแปร  โดยคลิกที่ cell ใน column ของ Width ดังรูป 
 

 

เปลี่ยนแปลงความกวางหรอืจํานวนหลัก
ไดโดยคลิกทีลู่กศรขึ้นลง 

 
  1.4 Decimals  เปนการกําหนดจํานวนหลักหลังจุดทศนิยมของคาตัวแปร โดยคลิกที่ cell 
ใน column ของ Decimals ถากําหนดชนิดของตัวแปรใน column ของ Type เปน String จะไมสามารถ
กําหนดคา Decimals ได 
 

 

เปลี่ยนแปลงจํานวนหลักทศนิยมของตวั
แปรไดโดยคลกิที่ลูกศรขึ้นลง 

 
  1.5 Label (ความหมายของตัวแปร)  Label เปน column ที่ใหระบุความหมายของตัว
แปร เน่ืองจากการตั้งชื่อตวัแปรจะใชคําไดไมเกิน 8 ตัวอักษร จึงควรระบคุวามหมายที่แทจริงของตัวแปร
ไว เชน ระดับการศึกษาใชชือ่ตัวแปรวา Edlevel จึงควรระบุความหมายไววา “ระดับการศึกษา” โดยพิมพ
ไวใน column ของ label และความหมายที่พิมพใน label จะไปแสดงในผลลัพธดวย 
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  1.6 Values (การกําหนดคาตัวแปร)  ใน column น้ีใหระบุคาและความหมายของตัวแปร 
ดังภาพ 
 

      

Click เพ่ือระบุคาและความหมายของตัวแปร 

 

 

ระบุความหมายของตัวแปร
ใน Value Label 

ระบุคาตัวแปรเปนตวัเลขใน Value 

 
เชน  กําหนดตัวแปรเพศ ตัง้ชื่อตัวแปรวา sex  กําหนดคา Value Labels โดยกําหนดคา Value = 1 และ 
Value Label = ชาย  แลวคลิก Add  จากนั้นกําหนดคา Value = 2 และคา Value Label = หญิง ดังภาพ 
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  1.7 การกําหนดคาสูญหาย (Missing Value) การเก็บขอมูลเพ่ือการวิจัยแตละครั้งจะมี
ขอมูลบางสวนสูญหายจากกรณีที่ผูตอบแบบสอบถาม  ตอบขอมูลไมครบ เม่ือคลิกใน column ของ 
missing จะไดหนาจอดังภาพ 

 

กรณีไมมีการพิมพขอมูล 

 

 

กรณีที่มีการกําหนดรหัสmissing กรณีน้ี
กําหนดใหใชรหัส 9 

 

 

กรณีใหผูตอบขามหรือไมตองตอบางขอ
ใหกําหนดรหัสของคําถามที่ตองขามไว

อีกรหัสหนึ่ง 
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  1.8 การกําหนดความของ Column เปน 8 ผูใชสามารถเปลี่ยนแปลงความกวางได โดย
คลิกที่ column จะไดดังภาพ 
 

 

Click ลูกศรขึน้ลงเพ่ือเลื่อนขนาดของความกวาง 

 
  1.9 Align เปนการกําหนดตําแหนงขอขอมูลใน cell ของแฟมขอมูลในหนาจอ โดยคลิก 
Align column ซ่ึงมีใหเลือก 3 ทาง คือ 1) Left = ขอมูลชิดซาย  2) Right = ขอมูลชิดขวา  และ 3) 
Center = ขอมูลอยูกลาง ดังภาพ 

 

Click ลูกศรแลวเลือก Left, Right หรือ Center 

  1.10 Measure เปนการกําหนด Scale ของขอมูลจะมีชนิดของ Scale ของขอมูลให
เลือก 3 ชนิด คือ 1) Scale = ขอมูลที่เปน Interval หรือ Ratio สามารถทราบไดวาตัวแปรใดมากกวากัน 
และมากกวากนัเทาไร 2) Ordinal = ขอมูลของตวัแปรที่สามารถแบงคาของตัวแปรไดเปนกลุมๆ สามารถ
ทราบไดวาตัวแปรใดมากกวากันแตไมทราบวามากกวากันอยูเทาไร  และ 3) Nominal = ขอมูลนาม
กําหนดที่แบงคาตัวแปรไดเปนกลุมๆ แตไมทราบวาตัวแปรใดมากกวากัน  

 

Click ลูกศรแลวเลือก Scale, Ordinal หรือ Nominal 
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 2. การพิมพขอมูลใน Data View 
 เม่ือสรางตัวแปรใน Variable View แลวใหคลิก Data View เพ่ือเปดหนาจอเขาสูการกรอก
ขอมูลใสลงในตัวแปรที่สรางไวแลว ดังภาพ 
 

 

Row หรือ 1 บรรทัด แบบสอบถาม 1 ชุด ไดจากการถามตัวอยาง 1 หนวย 
ถามีแบบสอบถาม 150 ชุดหนาจอนี้จะมีขอมูล 150 บรรทัด 

ชื่อตัวแปรที่ถกูกําหนดไวใน Variable 
View แลวในแตละ Column 

Click Data View เพ่ือเขาสูหนาจอสําหรับ
กรอกขอมูล 

 
การบันทึกแฟมขอมูล 

 หลังจากการสรางตัวแปรและกรอกขอมูลในตัวแปรทั้งหมดแลว  เม่ือตองการบันทึกแฟมใหใช
คําสั่งดังน้ี 
 File > Save as… จะไดหนาจอดังภาพ 

 

Click … File > Save as 
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จะไดหนาจอ Save Data As และใหตั้งชือ่ใน File 
name โดยจะมีนามสกุลเปน .sav 

 

 

File ที่บันทึกไวจะปรากฏใน 
Folder ที่เลือกไว 
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การวิเคราะหขอมูล 
  
 การวิเคราะหขอมูลสําหรับการวิจัยแตละครั้งน้ันมีคาสถิติที่จําเปนสาํหรับการวิเคราะหขอมูล 
อยู 2 สวน คอื 1) สถิติพ้ืนฐาน  และ 2) สถิตทิี่ใชทดสอบสมมติฐาน  ซ่ึงจะไดนําเสนอลําดับขัน้ตอนการ
วิเคราะหขอมูลดังน้ี 
 
สถิติพืน้ฐาน 
 เปนสถิตทิี่ใชกันบอยมากในการวิจัยแตละเรื่อง  ไดแก 1) คาความถี่ (Frequencies)   2)  คา
รอยละ (Percents) 3) คาเฉลี่ย (Mean : X ) และ 4) คาความเบี่ยงเบนมาตรฐาน (Standard Deviation 
: ) ซ่ึงสามารถวิเคราะหคาสถิตติามลําดบัไดโดยใชคําสั่งดังน้ี ..DS

 

Analyze > Descriptive Statistics > 
Frequencies…  จะไดหนาตางตอไปน้ี 

 

 

ทําแถมดําในตัวแปรที่ตองการหาคาความถี่
และคารอยละแลวคลิกทีลู่กศรเพื่อยาย 
ตัวแปรมาในกรอบของ Variable (s) 

 

 

คลิก Statistics เพ่ือเลือกคาสถิต ิ
ดังภาพดานลาง 
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 เม่ือตองการสรางกราฟใหคลิก Charts ในหนาตาง Frequencies จะไดหนาตาง Frequencies : 
Charts และใหเลือกลักษณะของกราฟตามตองการ กรณีน้ีตองการกราฟแทงใหคลิกที่ Bar Charts  
ดังภาพ 

 

คลิกเลือกคา Mean และ คา Ste. 
Deviation และคลิก Continue และคลิก 

OK ที่กรอบ Frequencies  
จะไดผลลัพธ (Output) ดังภาพ 

ผูชายมีจํานวน 6 คน คิดเปน 60 % ใน
ชอง Valid Percent คือ รอยละของผูชาย
ที่หักคาสูญหายออกแลวกรณีน้ีไมมีคาสูญ
หายจึงมีคา Valid Percent เปน 60 % 

เลือก Bar charts คลิก Continue และคลิก OK 
จะไดกราฟดังภาพ 
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 การวิเคราะหคาคาเฉลีย่ (Mean : X ) และ 4) คาความเบี่ยงเบนมาตรฐาน (Standard 
Deviation : ) กรณีตองการหาคาเฉลี่ยและคาความเบี่ยงเบนมาตรฐานของตัวแปรตน (ตวัแปรเพศ) 
เพ่ือจัดระดับของตัวแปรตามในแบบสอบถามใหปฏิบตัิตามลําดบัขัน้ดังน้ี 

..DS

 

 

Analyze > Compare Means > Mean 
จะไดหนาตางดังภาพดานลางนี้ 

 

 

เลือกตวัแปรเพศ แลวคลิกลูกศร  ในชอง 
Independent List : 

เลือกตวัแปรตามทั้ง 10 ขอ และคลิก ในชอง Dependent 
List : จากนั้นคลิก Options เพ่ือเลือกคาสถิติดังภาพ 

 
 
 

 

เลือกคา Mean และ Standard 
Deviation แลวคลิก Continue 

จากนั้นคลิก OK จะไดผลลพัธดังภาพ 
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คาเฉลี่ยและคาความเบี่ยงเบนมาตรฐาน
รายขอของตัวแปรเพศ (ชาย + หญิง) 

คาเฉลี่ยและคาความเบี่ยงเบนมาตรฐาน
รายขอของเพศชายและหญงิ 

 
การวิเคราะหสถิติที่ใชในการทดสอบสมมติฐาน 
 สถิติทีใ่ชในการทดสอบสมมติฐานผูที่จะวิเคราะหขอมูลตองทราบวา  งานวิจัยแตละชิ้นตองการ
คําตอบอะไร เชน 1) ตองการเปรียบเทียบความคิดเห็นของตัวแปรตน 2 ตัว หรือ มากกวา 2 ตัว จะตอง
ใชสถติิตวัใดมาใชในการวิเคราะหผล  หรือ การหาความสัมพันธระหวางตวัแปร 2 ตัว เปนตน  ใน
เอกสารนี้จะนําเสนอการใชสถิติเพ่ือใชทดสอบสมมติฐานที่สาํคัญและใชกันมากในการวิจัยทั่วไป ดังน้ี 
 1. การทดสอบคา t ที่มตีัวแปรตน 2 ตัว เปนอิสระตอกันใชการทดสอบแบบ 
independent  t – test  
 โดยดําเนินการดังน้ี เม่ือเปดแฟมขอมูลเขาไปแลวใหเลือกตามลําดบัขั้นตอนดังภาพ 
 

          
Analyze > Compare Means > Independent – Samples T Test 

จะปรากฏหนาตางดังภาพดานลาง 
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และใหเลือกตวัแปรตามทีต่องการทดสอบ
จากนั้นคลิกที่ ใน Test Variables 

และคลิกตวัแปรเพ่ือ Grouping Variable 
ดังภาพ 

จะปรากฏหนาตาง Define Groups ให
เลือก Group 1 และ 2 ดังภาพ จากนั้น
คลิก Continue และ คลิก Options เพ่ือ

เลือกคา Confidence Interval ที่
ตองการ ดังภาพดานลาง 

ใหเลือกตวัแปรที่ตองการทดสอบใน
ที่น้ีตวัแปรเพศ (ช – ญ) เปนตัว
แปรที่เปนอิสระตอกัน แลวคลิก 

ใน Grouping Variable 

 

 

เลือกคา Confidence Interval ที่ 95 % 
และคลิก Continue และ OK จะได

ผลลัพธดังภาพดานลาง 
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 ผลลัพธที่ไดจากการทดสอบคา Independent t – test จะปรากฏตาราง 2 ตาราง ไดแก 1) 
ตารางคา Group Statistics และ 2) ตารางคา Independent Samples Test ดังภาพ 

 

 

ขอ 1_a = ตัวแปรตาม 
เพศชาย และ หญิง = ตวัแปรตน 
N = จํานวนตวัอยาง  
Mean = คาเฉลี่ย 
Std. Deviation = คาความ
เบี่ยงเบนมาตรฐาน 
Std. Error Mean = ความคลาด 
เคลื่อนมาตรฐานของคาเฉลีย่ 

2. สมมติวากําหนดคา Alpha = .05 กรณีน้ีคา 
Sig.ของ F มีคา .053 ซ่ึงมีคา > Alpha จึง
สรุปผลจาก Sig.(2-tailed) = .077 ซ่ึง > .05 
จึงสรุปวา เพศชายและหญงิมีความคิดเห็นไม
แตกตางกันทีร่ะดับนัยสําคญัทางสถิติ .05 
หรือ p ≥ .05 

1. พิจารณาคา Sig. ของคา F ถา Sig. > 
Alpha ใหพิจารณาคา Sig. (2-tailed) ของ
คา t จะมีคา > Alpha เชนกัน 
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 2. การทดสอบคา t แบบคูอันดับ (Paired Sample Test)  
 การทดสอบคา t กรณีเปนแบบคูอันดับใหดําเนินการโดยเขาสูแฟมขอมูลและดาํเนินการตาม
ขั้นตอนดังภาพ 
 

 

Analyze > Compare Means > Paired – 
Samples T Test… คลิกจะเปดหนาตางดัง
ภาพดานลางตอไป 

 
 

 

คลิกเลือก a_01 และ b_01 จากนั้น
คลิกเครื่องหมาย จะปรากฏดังภาพ
ทําเชนนี้จนครบทุกคู  เม่ือครบทุกคู
แลวเลือก Options จะปรากฏหนาตาง
ดังภาพ 

 
 

 

คลิก Continue และ OK 
จะปรากฏผลลัพธดัง
หนาตางของภาพตอไป 

 
 
 การทดสอบคา t แบบคูอันดับจะปรากฏตาราง 3 ตาราง ไดแก 1) Paired Samples Statistic  
2) Paired Samples Correlations  และ 3) Paired Samples Test การพิจารณาผลการทดสอบคา t ให
พิจารณาจากตาราง Paired Samples Test ดังน้ี 
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การแปลความหมายของผลการวิเคราะหขอมูลให
พิจารณาที่คา Sig.(2-tailed) ถาคา Sig.>Alpha ให
สรุปวาไมมีความแตกตางกนั กรณีน้ีกําหนดใหคา Alpha 
= .05 ดังน้ัน t = -.487 Sig.(2-tailed)=.638 จึงสรุปวา 
ขอ1_a ไมมีความแตกตางกับ ขอ1_b ที่ระดับนัยสําคัญ
ทางสถิติ .05 หรือ p ≥.05 
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 3. การทดสอบสมมติฐานเพื่อเปรียบเทยีบตวัแปรตนที่มีมากกวา 2 ตัวข้ึนไป  
ใหทดสอบคา F    โดยมีขั้นตอนการวิเคราะหขอมูลดังน้ี 

 

Analyze > Compare Means > One Way ANOVA 
จะไดหนาตางดังภาพตอไปน้ี 

 

 

เลือก Contrasts จะไดหนาตางดังภาพ 

เลือกตวัแปรตามแลวคลิก ในกรอบของ 
Dependent List 

เลือกตวัแปรตนที่มีมากกวา 2 กลุมขึ้นไป แลว
คลิก ในกรอบ Factor 

 

 

เลือก Polynomial และคลิก Continue 
จากนั้นคลิก Post Hoc… 

 

 

เลือก Scheffe และคลิก Continue 
จากนั้นคลิก Options… 
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เลือก Descriptive และคลกิ Continue 
จากนั้นคลิก OK จะไดผลลพัธในหนาตางตอไปน้ี 

 
 การทดสอบคา F จะปรากฏตาราง 3 ตาราง ไดแก 1) Descriptive   2) ANOVA  และ 3) 
Multiple Comparisons ดังภาพ 

 
 
 
 
 



24 

 

พิจารณาที่คา Sig.ของคา F ถา > .05 สรุปวามี
ความคิดเห็นแตกตางกันระหวางกลุม ใหพิจารณา
คาในตาราง Multiple Comparisons ตอไป 

 

 

ถาคาเฉลีย่ของประชากรแตกตาง
กันจะมีเครื่องหมาย * อยูเหนือ
ตัวเลขในคา M.D. 

กรณีน้ีคาระดับนัยสําคัญที่ระดับ .05 พบ
ความแตกตางกันของคาเฉลี่ยจํานวน 2 คู 
คือ ผูบริหารกับหัวหนางาน และ หัวหนา
งานกับพนักงาน สวนผูบริหารกับพนักงาน
ไมพบความแตกตางกัน  
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ตารางเปรียบเทียบรายคูของตัวแปรจากการทดสอบคา F 
 
 ผูบริหาร (X1) หัวหนางาน (X2) พนักงาน (X3) 

ผูบริหาร (X1) 0 -2.00∗

P = .04 
-.40 

P = .785 

หัวหนางาน (X2) 
2.00∗ 

P = .04 
0 1.60∗

P = .04 

พนักงาน (X3) 
.40 

P = .785 
-1.60∗ 

P = .04 
0 

 
 สรุปไดวา มีความแตกตางกันของคาเฉลีย่ 2 คู ไดแก X1 กับ  X2  และ X2 กับ X3 ซ่ึงมีคาเฉลี่ย
แตกตางกันอยางมีนัยสําคัญทางสถิตทิี่ระดับ .05 หรือ p ≤ .05  สวน X1 กับ X3 ไมมีความแตกตางกันที่
ระดับนัยสําคญัทางสถิตทิี่ระดับ .05 หรือ p ≥ .05 
 
 4. การวิเคราะหคาสหสัมพันธ (Correlation Analysis) 
 สัมประสิทธิส์หสัมพันธ (r) เปนมาตรวดัระดับความเกี่ยวของหรือความสัมพันธกัน r มีคาอยู
ระหวาง -1…..ถึง…..+1  
 ถา X, Y มีคาเพิ่มขึ้นหรือลดลงไปในทศิทางเดียวกันแลว  r จะมีคาเปน + (บวก) 
 ถา X, Y มีคาเพิ่มขึ้นหรือลดลงไปในทศิทางตรงกันขามแลว r จะมีคาเปน – (ลบ)  
 ในที่น้ีจะนําเสนอการวิเคราะหคาสหสัมพันธแบบโมเมนต เพียงวธิเีดียวเนื่องจากเปนคาสถติทิี่
นิยมใชกันมากที่สุด  โดยใหดําเนินการตามขั้นตอนดังภาพ 
 

 

Analyze > Correlate > Bivariate 
แลวคลิกจะเปดหนาตางดังภาพตอไป 
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เลือกตวัแปรที่ตองการวิเคราะหคา r 
แลวคลิก ตวัแปรจะยายเขามาอยู
ใน Variables แลวเลือก Pearson 
และคลิก Option เพ่ือเลือกคาสถิติ
ดังภาพ 

 

 

เลือกคา Means and standard 
deviations และคลิก Continue 
จากนั้นคลิก OK จะไดหนาตาง
แสดงผลลัพธ ดังภาพ 

 

 

ตัวแปรที่ตองการศึกษา
ความสัมพันธ 

การพิจารณาวาตวัแปรคูใดมีความสัมพันธทางใดใหดู
ที่คา Sig.(2-tailed) ถามีคาต่ํากวาคา Alpha คือ นอย
กวา .05 สรุปวามีความสัมพันธกันอยางมีนัยสําคัญ
ทางสถิตทิี่ระดับ .05 และใหสังเกตคา r จะมี
เครื่องหมาย * ปรากฏอยู กรณีน้ีเรียกวา ขอ3_a มี
ความสัมพันธทางบวกกบัขอ3_b (คา r เปนบวก) 
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 5. การหาคาความเชื่อมั่นของเคร่ืองมือ (Reliability Analysis) 
  การหาคุณภาพของเครื่องมือดานความเชือ่ม่ัน  เปนขั้นตอนหนึ่งที่จะทําใหม่ันใจไดวา
เครื่องมือสําหรับการวิจัยน้ันสามารถใหคะแนนไดอยางม่ันใจไดวาไมคลาดเคลื่อน  โดยปกติการหา
คุณภาพดานความเชื่อม่ันของเครื่องมือน้ันมีอยู 3 วิธ ีคือ 1) การทดสอบซ้ํา (test – retest)  2) แบบแบง
ครึ่ง (split – half method หรือ odd – even method) และ 3) แบบวธิีของคูเดอร ริชารดสัน (Kuder – 
Richardson) ในการหาคาความเชื่อม่ันของเครื่องมือที่เปนแบบสอบถามที่มีลักษณะเปนแบบประมาณคา 
5 ระดับ น้ันจะใชวธิีของครอนบาค (Cronbach) ซ่ึงเปนการปรับปรุงมาจากวธิีของคูเดอร ริชารดสัน 
เรียกวา สัมประสิทธิ์แอลฟา (Alpha Coefficient) ในกรณีน้ีจะนําเสนอการวิเคราะหคาความเชื่อม่ันจาก
แบบสอบถามที่มีลักษณะเปนแบบประมาณคา 5 ระดับ โดยใชวธิีของ ครอนบาค (Cronbach) เทานั้น 
โดยดําเนินการตามลําดับขัน้ดังน้ี 

 

Analyze > Scale > Reliability Analysis… 
คลิกจะไดหนาตางดังภาพตอไป 

 

 

เลือกขอคําถามที่ตองการ
คํานวณแลวคลิก ขอคําถาม
จะเขามาอยูในกรอบ Items 
และเลือก Model ของการ
คํานวณคา กรณีน้ีเลือก Model 
เปน Alpha จากนั้นเลือก 
Statistics ดังภาพตอไป 
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เลือก Item, Means และ 
Correlations คลิก Continue และ
คลิก OK จะไดผลลัพธดังภาพ 

 

 

คาสัมประสิทธิ์แอลฟาจะมีคาอยูระหวาง 0 – 1.00 
คาความเชื่อม่ันใกล 1 มากเทาไรหมายความวา
แบบสอบถามชุดนั้นมีความเชื่อม่ันสูง แตถาคา
ความเชื่อม่ันอยูใกล 0 สรปุวาแบบสอบถามนั้นไม
มีความเชื่อม่ัน 

 
 
 
 
 
 
 
 
 
เอกสารอางอิง 
กัลยา  วานิชบัญชา. (2547). การใช SPSS for Windows ในการวิเคราะหขอมูล. กรุงเทพฯ : ภาควิชา 
            สถิติ  คณะพาณิชยศาสตรและการบัญชี  จุฬาลงกรณมหาวิทยาลัย. 
ฉัตรศิริ  ปยะพิมลสิทธิ์. (2548). การใช SPSS เพ่ือการวิเคราะหขอมูล. สงขลา : ภาควิชาการประเมินผล 
            และวิจัย  คณะศึกษาศาสตร  มหาวิทยาลัยทกัษิณ. 


