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การวิเคราะหขอมูลดวยโปรแกรม SPSS 
 

 โปรแกรม SPSS for Windows (Statistical Package for Social Science) เปนโปรแกรม
สําเร็จรูปที่ใชสําหรับการวิเคราะหขอมูลทางสถิติ  สามารถสรางแฟมขอมูลและวิเคราะหขอมูลไดอยางมี
ประสิทธิภาพ  ซ่ึงผลลัพธสามารถแสดงออกมาในรูปของตาราง ขอความ  และแผนภูมิรูปตางๆ เชน 
แผนภูมิแทง  แผนภูมิเสน  และแผนภูมิวงกลม เปนตน 
 

การเริ่มตนเขาสูโปรแกรม SPSS 
 1. Double Click ที่ Icon ของ SPSS บนจอ Desktop รูป                             หรือเขาทาง 
Start > Programs > SPSS  ดังรูป 

ortcut to spsswin  

 

 

คลิก 1 ครั้ง เพื่อเขาสูโปรแกรม SPSS 

 

 2. เม่ือเขาสูโปรแกรม SPSS ไดแลวจะปรากฏหนาตางตอไปน้ี 

          

คลิก Type in data และคลกิ OK จะปรากฏ
หนาตาง SPSS Editor สําหรับปอนขอมูล 

หรือ Double Click ที่ชื่อแฟมขอมูลกรณีมี
แฟมขอมูลอยูแลว 
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สวนประกอบทั่วไปของโปรแกรม SPSS 
 หลังจากเขาสูโปรแกรมแลวจะขอแนะนําโครงสรางสวนประกอบโดยทั่วไปของโปรแกรม SPSS 
กอนที่จะดําเนินการวิเคราะหขอมูลตอไป  โดยจะนําเสนอคําอธิบายตามภาพประกอบดานลางนี้ 
 
 
 
 
 
 

 

4) Cell Editor = กําหนดคาตัวแปร 

3) Variables = กําหนดชื่อตัวแปร 

2) Menu Bar 

1) Title Bar 

6) Cases = ชุดของตัวแปร 

5) Cell = สําหรับกําหนดตวัแปร 

 
 
 
 

 
 
 

7) Status Bar = แสดงสถานะการทํางาน 

9) Variables view = สรางและแกไขโครงสรางตัวแปร 

8) View Bar 

10) Data view = เพ่ิมและแกไขขอมูลตวัแปร 
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มุมมอง (View Bar)  
 เปนการแบงสวนงานออกเปน 2 สวน ไดแก Variable View และ Data View  
 

 

Click 

 
แตละสวนมีหนาที่สําคัญดังน้ี 
 1. Variable View  เปนสวนที่ทําหนาทีส่รางหรือแกไขตวัแปร โดยตองกําหนดชื่อ ชนิด ความ
ยาว และความหมายของตัวแปร และใชในการตรวจสอบรายละเอียดของตัวแปร  ดังภาพ 
 
 
 
 
 
 

 
 
 
 
 
 

กําหนดชื่อตัวแปร 

กําหนดชนิดตัวแปร/ความกวางและทศนยิมของตัวแปร 

ความหมายของตัวแปร 

กําหนดคาของตัวแปร 
คาสูญหายใช 9 แทน กําหนดมาตรวัดตวัแปร 

การจัดขอมูลใหชิดซาย,ขวา,กลาง 

ความกวางสําหรับกรอกขอมูล 
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 2. Data View  เปนหนาจอสําหรับกรอกขอมูลตามตวัแปรที่กําหนดใน Variable view 
 

 
 
 

ชองสําหรับกรอกขอมูลตามตัวแปร 
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การสรางแฟมขอมูลจากแบบสอบถาม 
 
 การสรางแฟมขอมูลจากโปรแกรม SPSS น้ัน หลังจากเขาสูโปรแกรมแลวจะไดหนาจอ 
Untitled – SPSS Data Editor  ซ่ึงมี 2 tab  ที่อยูดานลางซายมือ  คือ  Variable View และ Data View  
ดังภาพ 

 

Click Variable View 

 
 หลังจากนั้นใหคลิกที่ Variable View ดานลางซายมือ เพ่ือเขาสูหนาจอสําหรับการสรางและ
กําหนดตัวแปร 
ขั้นตอนการสรางแฟมขอมูล 
 1. การกําหนดตัวแปร  ตองแปลงคําตอบจากขอคําถามในแบบสอบถามใหเปนตัวแปร  
โดยคําถาม 1 คําถามในแบบสอบถามสามารถสรางเปนตวัแปรไดอยางนอย 1 ตัว โดยเขาไปสรางตัว
แปรใน Variable View  
 
 

 

1 Row / 1 บรรทัด 
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  1.1 การตั้งชือ่ตัวแปร (name) 
   ในการตั้งชื่อตวัแปรผูใชควรกําหนดชื่อตัวแปร ใหสอดคลองกับความหมายของคาตัว
แปร เชน อายุ ควรตั้งชื่อเปน age เพศ ควรตั้งชื่อเปน sex หรือ gender สวนรายได ควรตั้งชื่อเปน 
income เปนตน 
  การตั้งชื่อตวัแปรในโปรแกรม SPSS มีขอจํากัดดังน้ี 

1) ความยาวของชื่อตองไมเกิด 8 ตัวอักษร 
  2) ชื่อตัวแปรตองขึ้นตนดวยตวัอักษรเทานัน้สวนตวัอ่ืนๆ จะเปนตัวเลขหรือสัญลกัษณ
พิเศษก็ได เชน &,©,δ, หรือ β ก็ได 
  3) ตัวแปรตองไมจบหรือลงทายดวยจุด (.) และหามใชสญัลักษณ !,?,‘ และ ∗ ในการตั้ง
ชื่อตัวแปร  
  4) ชื่อตัวแปรในแฟมขอมูลเดียวกันตองไมซํ้ากัน และการใชตวัอักษรใหญหรือเล็กถอืวา
เปนตวัแปรตวัเดียวกัน  เชน  Sex,  SEX,  sex 
  5) หามใชคําตอไปน้ีเปนชื่อตวัแปร  ALL  NE  EQ  TO  LE  LT  BY  OR  GT  AND  
GE  WITH   
  1.2 ชนิดของตวัแปร 
   หลังจากตั้งชือ่ตัวแปรแลวใหคลิกที่ column ของ type จะปรากฏดังภาพ 
 

 

Click ที่ Numeric จะ
ปรากฏ Variable Type 

ดังภาพดานลาง 

 

 

   

เลือกความกวาง
และทศนิยม 
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 ในหนาจอ Variable Type จะแบงตัวแปรออกเปน 8 ชนิด ดังน้ี 
 1) Numeric  เปนตัวแปรชนิดที่เปนตวัเลขทั้งที่มีคาเปนบวกและลบ 
 2) Comma เปนตวัแปรชนิดที่เปนทั้งตวัเลข จุดทศนยิม  และมีเครื่องหมาย Commaคั่น 
 3) Dot  เปนตัวแปรที่รวมทั้งตวัเลข มี Comma คั่น และใชเครื่องหมายจุด 
 4) Scientific Notation เปนตัวแปรที่มีคาเปนตัวเลข และสัญลักษณทางวิทยาศาสตร 
 5) Date  เปนตัวแปรชนิดที่เปนวันที่ ขอมูลจะอยูในรูปของวันเดือนป 
 6) Dollar เปนตวัแปรที่เปนชนิดตัวเลขและหมายถงึตัวเงินที่มีเครื่องหมาย $ มีจุด และ
เครื่องหมาย Comma คั่น 
 7) Custom  แบงเปน 5 รูปดวยกัน คือ CCA, CCB, CCC, CCD และ CCE  
 8) String  เปนตวัแปรทีมี่คาเปนตวัอักษร ตัวเลข หรือเครื่องหมายตางๆ ได เม่ือเลือกชนิด 
String จะตองกําหนดความกวาง 
  1.3 Width (การกําหนดขนาดของตัวแปร) เปนการกําหนดขนาดความกวางของตวัแปร
หรือจํานวนหลักของตวัแปร  โดยคลิกที่ cell ใน column ของ Width ดังรูป 
 

 

เปลี่ยนแปลงความกวางหรอืจํานวนหลัก
ไดโดยคลิกทีลู่กศรขึ้นลง 

 
  1.4 Decimals  เปนการกําหนดจํานวนหลักหลังจุดทศนิยมของคาตัวแปร โดยคลิกที่ cell 
ใน column ของ Decimals ถากําหนดชนิดของตัวแปรใน column ของ Type เปน String จะไมสามารถ
กําหนดคา Decimals ได 
 

 

เปลี่ยนแปลงจํานวนหลักทศนิยมของตวั
แปรไดโดยคลกิที่ลูกศรขึ้นลง 

 
  1.5 Label (ความหมายของตัวแปร)  Label เปน column ที่ใหระบุความหมายของตัว
แปร เน่ืองจากการตั้งชื่อตวัแปรจะใชคําไดไมเกิน 8 ตัวอักษร จึงควรระบคุวามหมายที่แทจริงของตัวแปร
ไว เชน ระดับการศึกษาใชชือ่ตัวแปรวา Edlevel จึงควรระบุความหมายไววา “ระดับการศึกษา” โดยพิมพ
ไวใน column ของ label และความหมายที่พิมพใน label จะไปแสดงในผลลัพธดวย 
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  1.6 Values (การกําหนดคาตัวแปร)  ใน column น้ีใหระบุคาและความหมายของตัวแปร 
ดังภาพ 
 

      

Click เพ่ือระบุคาและความหมายของตัวแปร 

 

 

ระบุความหมายของตัวแปร
ใน Value Label 

ระบุคาตัวแปรเปนตวัเลขใน Value 

 
เชน  กําหนดตัวแปรเพศ ตัง้ชื่อตัวแปรวา sex  กําหนดคา Value Labels โดยกําหนดคา Value = 1 และ 
Value Label = ชาย  แลวคลิก Add  จากนั้นกําหนดคา Value = 2 และคา Value Label = หญิง ดังภาพ 
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  1.7 การกําหนดคาสูญหาย (Missing Value) การเก็บขอมูลเพ่ือการวิจัยแตละครั้งจะมี
ขอมูลบางสวนสูญหายจากกรณีที่ผูตอบแบบสอบถาม  ตอบขอมูลไมครบ เม่ือคลิกใน column ของ 
missing จะไดหนาจอดังภาพ 

 

กรณีไมมีการพิมพขอมูล 

 

 

กรณีที่มีการกําหนดรหัสmissing กรณีน้ี
กําหนดใหใชรหัส 9 

 

 

กรณีใหผูตอบขามหรือไมตองตอบางขอ
ใหกําหนดรหัสของคําถามที่ตองขามไว

อีกรหัสหนึ่ง 
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  1.8 การกําหนดความของ Column เปน 8 ผูใชสามารถเปลี่ยนแปลงความกวางได โดย
คลิกที่ column จะไดดังภาพ 
 

 

Click ลูกศรขึน้ลงเพ่ือเลื่อนขนาดของความกวาง 

 
  1.9 Align เปนการกําหนดตําแหนงขอขอมูลใน cell ของแฟมขอมูลในหนาจอ โดยคลิก 
Align column ซ่ึงมีใหเลือก 3 ทาง คือ 1) Left = ขอมูลชิดซาย  2) Right = ขอมูลชิดขวา  และ 3) 
Center = ขอมูลอยูกลาง ดังภาพ 

 

Click ลูกศรแลวเลือก Left, Right หรือ Center 

  1.10 Measure เปนการกําหนด Scale ของขอมูลจะมีชนิดของ Scale ของขอมูลให
เลือก 3 ชนิด คือ 1) Scale = ขอมูลที่เปน Interval หรือ Ratio สามารถทราบไดวาตัวแปรใดมากกวากัน 
และมากกวากนัเทาไร 2) Ordinal = ขอมูลของตวัแปรที่สามารถแบงคาของตัวแปรไดเปนกลุมๆ สามารถ
ทราบไดวาตัวแปรใดมากกวากันแตไมทราบวามากกวากันอยูเทาไร  และ 3) Nominal = ขอมูลนาม
กําหนดที่แบงคาตัวแปรไดเปนกลุมๆ แตไมทราบวาตัวแปรใดมากกวากัน  

 

Click ลูกศรแลวเลือก Scale, Ordinal หรือ Nominal 



12 

 2. การพิมพขอมูลใน Data View 
 เม่ือสรางตัวแปรใน Variable View แลวใหคลิก Data View เพ่ือเปดหนาจอเขาสูการกรอก
ขอมูลใสลงในตัวแปรที่สรางไวแลว ดังภาพ 
 

 

Row หรือ 1 บรรทัด แบบสอบถาม 1 ชุด ไดจากการถามตัวอยาง 1 หนวย 
ถามีแบบสอบถาม 150 ชุดหนาจอนี้จะมีขอมูล 150 บรรทัด 

ชื่อตัวแปรที่ถกูกําหนดไวใน Variable 
View แลวในแตละ Column 

Click Data View เพ่ือเขาสูหนาจอสําหรับ
กรอกขอมูล 

 
การบันทึกแฟมขอมูล 

 หลังจากการสรางตัวแปรและกรอกขอมูลในตัวแปรทั้งหมดแลว  เม่ือตองการบันทึกแฟมใหใช
คําสั่งดังน้ี 
 File > Save as… จะไดหนาจอดังภาพ 

 

Click … File > Save as 
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จะไดหนาจอ Save Data As และใหตั้งชือ่ใน File 
name โดยจะมีนามสกุลเปน .sav 

 

 

File ที่บันทึกไวจะปรากฏใน 
Folder ที่เลือกไว 
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การวิเคราะหขอมูล 
  
 การวิเคราะหขอมูลสําหรับการวิจัยแตละครั้งน้ันมีคาสถิติที่จําเปนสาํหรับการวิเคราะหขอมูล 
อยู 2 สวน คอื 1) สถิติพ้ืนฐาน  และ 2) สถิตทิี่ใชทดสอบสมมติฐาน  ซ่ึงจะไดนําเสนอลําดับขัน้ตอนการ
วิเคราะหขอมูลดังน้ี 
 
สถิติพืน้ฐาน 
 เปนสถิตทิี่ใชกันบอยมากในการวิจัยแตละเรื่อง  ไดแก 1) คาความถี่ (Frequencies)   2)  คา
รอยละ (Percents) 3) คาเฉลี่ย (Mean : X ) และ 4) คาความเบี่ยงเบนมาตรฐาน (Standard Deviation 
: ) ซ่ึงสามารถวิเคราะหคาสถิตติามลําดบัไดโดยใชคําสั่งดังน้ี ..DS

 

Analyze > Descriptive Statistics > 
Frequencies…  จะไดหนาตางตอไปน้ี 

 

 

ทําแถมดําในตัวแปรที่ตองการหาคาความถี่
และคารอยละแลวคลิกทีลู่กศรเพื่อยาย 
ตัวแปรมาในกรอบของ Variable (s) 

 

 

คลิก Statistics เพ่ือเลือกคาสถิต ิ
ดังภาพดานลาง 
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 เม่ือตองการสรางกราฟใหคลิก Charts ในหนาตาง Frequencies จะไดหนาตาง Frequencies : 
Charts และใหเลือกลักษณะของกราฟตามตองการ กรณีน้ีตองการกราฟแทงใหคลิกที่ Bar Charts  
ดังภาพ 

 

คลิกเลือกคา Mean และ คา Ste. 
Deviation และคลิก Continue และคลิก 

OK ที่กรอบ Frequencies  
จะไดผลลัพธ (Output) ดังภาพ 

ผูชายมีจํานวน 6 คน คิดเปน 60 % ใน
ชอง Valid Percent คือ รอยละของผูชาย
ที่หักคาสูญหายออกแลวกรณีน้ีไมมีคาสูญ
หายจึงมีคา Valid Percent เปน 60 % 

เลือก Bar charts คลิก Continue และคลิก OK 
จะไดกราฟดังภาพ 

 



16 

 การวิเคราะหคาคาเฉลีย่ (Mean : X ) และ 4) คาความเบี่ยงเบนมาตรฐาน (Standard 
Deviation : ) กรณีตองการหาคาเฉลี่ยและคาความเบี่ยงเบนมาตรฐานของตัวแปรตน (ตวัแปรเพศ) 
เพ่ือจัดระดับของตัวแปรตามในแบบสอบถามใหปฏิบตัิตามลําดบัขัน้ดังน้ี 

..DS

 

 

Analyze > Compare Means > Mean 
จะไดหนาตางดังภาพดานลางนี้ 

 

 

เลือกตวัแปรเพศ แลวคลิกลูกศร  ในชอง 
Independent List : 

เลือกตวัแปรตามทั้ง 10 ขอ และคลิก ในชอง Dependent 
List : จากนั้นคลิก Options เพ่ือเลือกคาสถิติดังภาพ 

 
 
 

 

เลือกคา Mean และ Standard 
Deviation แลวคลิก Continue 

จากนั้นคลิก OK จะไดผลลพัธดังภาพ 
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คาเฉลี่ยและคาความเบี่ยงเบนมาตรฐาน
รายขอของตัวแปรเพศ (ชาย + หญิง) 

คาเฉลี่ยและคาความเบี่ยงเบนมาตรฐาน
รายขอของเพศชายและหญงิ 

 
การวิเคราะหสถิติที่ใชในการทดสอบสมมติฐาน 
 สถิติทีใ่ชในการทดสอบสมมติฐานผูที่จะวิเคราะหขอมูลตองทราบวา  งานวิจัยแตละชิ้นตองการ
คําตอบอะไร เชน 1) ตองการเปรียบเทียบความคิดเห็นของตัวแปรตน 2 ตัว หรือ มากกวา 2 ตัว จะตอง
ใชสถติิตวัใดมาใชในการวิเคราะหผล  หรือ การหาความสัมพันธระหวางตวัแปร 2 ตัว เปนตน  ใน
เอกสารนี้จะนําเสนอการใชสถิติเพ่ือใชทดสอบสมมติฐานที่สาํคัญและใชกันมากในการวิจัยทั่วไป ดังน้ี 
 1. การทดสอบคา t ที่มตีัวแปรตน 2 ตัว เปนอิสระตอกันใชการทดสอบแบบ 
independent  t – test  
 โดยดําเนินการดังน้ี เม่ือเปดแฟมขอมูลเขาไปแลวใหเลือกตามลําดบัขั้นตอนดังภาพ 
 

          
Analyze > Compare Means > Independent – Samples T Test 

จะปรากฏหนาตางดังภาพดานลาง 
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และใหเลือกตวัแปรตามทีต่องการทดสอบ
จากนั้นคลิกที่ ใน Test Variables 

และคลิกตวัแปรเพ่ือ Grouping Variable 
ดังภาพ 

จะปรากฏหนาตาง Define Groups ให
เลือก Group 1 และ 2 ดังภาพ จากนั้น
คลิก Continue และ คลิก Options เพ่ือ

เลือกคา Confidence Interval ที่
ตองการ ดังภาพดานลาง 

ใหเลือกตวัแปรที่ตองการทดสอบใน
ที่น้ีตวัแปรเพศ (ช – ญ) เปนตัว
แปรที่เปนอิสระตอกัน แลวคลิก 

ใน Grouping Variable 

 

 

เลือกคา Confidence Interval ที่ 95 % 
และคลิก Continue และ OK จะได

ผลลัพธดังภาพดานลาง 
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 ผลลัพธที่ไดจากการทดสอบคา Independent t – test จะปรากฏตาราง 2 ตาราง ไดแก 1) 
ตารางคา Group Statistics และ 2) ตารางคา Independent Samples Test ดังภาพ 

 

 

ขอ 1_a = ตัวแปรตาม 
เพศชาย และ หญิง = ตวัแปรตน 
N = จํานวนตวัอยาง  
Mean = คาเฉลี่ย 
Std. Deviation = คาความ
เบี่ยงเบนมาตรฐาน 
Std. Error Mean = ความคลาด 
เคลื่อนมาตรฐานของคาเฉลีย่ 

2. สมมติวากําหนดคา Alpha = .05 กรณีน้ีคา 
Sig.ของ F มีคา .053 ซ่ึงมีคา > Alpha จึง
สรุปผลจาก Sig.(2-tailed) = .077 ซ่ึง > .05 
จึงสรุปวา เพศชายและหญงิมีความคิดเห็นไม
แตกตางกันทีร่ะดับนัยสําคญัทางสถิติ .05 
หรือ p ≥ .05 

1. พิจารณาคา Sig. ของคา F ถา Sig. > 
Alpha ใหพิจารณาคา Sig. (2-tailed) ของ
คา t จะมีคา > Alpha เชนกัน 
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 2. การทดสอบคา t แบบคูอันดับ (Paired Sample Test)  
 การทดสอบคา t กรณีเปนแบบคูอันดับใหดําเนินการโดยเขาสูแฟมขอมูลและดาํเนินการตาม
ขั้นตอนดังภาพ 
 

 

Analyze > Compare Means > Paired – 
Samples T Test… คลิกจะเปดหนาตางดัง
ภาพดานลางตอไป 

 
 

 

คลิกเลือก a_01 และ b_01 จากนั้น
คลิกเครื่องหมาย จะปรากฏดังภาพ
ทําเชนนี้จนครบทุกคู  เม่ือครบทุกคู
แลวเลือก Options จะปรากฏหนาตาง
ดังภาพ 

 
 

 

คลิก Continue และ OK 
จะปรากฏผลลัพธดัง
หนาตางของภาพตอไป 

 
 
 การทดสอบคา t แบบคูอันดับจะปรากฏตาราง 3 ตาราง ไดแก 1) Paired Samples Statistic  
2) Paired Samples Correlations  และ 3) Paired Samples Test การพิจารณาผลการทดสอบคา t ให
พิจารณาจากตาราง Paired Samples Test ดังน้ี 
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การแปลความหมายของผลการวิเคราะหขอมูลให
พิจารณาที่คา Sig.(2-tailed) ถาคา Sig.>Alpha ให
สรุปวาไมมีความแตกตางกนั กรณีน้ีกําหนดใหคา Alpha 
= .05 ดังน้ัน t = -.487 Sig.(2-tailed)=.638 จึงสรุปวา 
ขอ1_a ไมมีความแตกตางกับ ขอ1_b ที่ระดับนัยสําคัญ
ทางสถิติ .05 หรือ p ≥.05 
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 3. การทดสอบสมมติฐานเพื่อเปรียบเทยีบตวัแปรตนที่มีมากกวา 2 ตัวข้ึนไป  
ใหทดสอบคา F    โดยมีขั้นตอนการวิเคราะหขอมูลดังน้ี 

 

Analyze > Compare Means > One Way ANOVA 
จะไดหนาตางดังภาพตอไปน้ี 

 

 

เลือก Contrasts จะไดหนาตางดังภาพ 

เลือกตวัแปรตามแลวคลิก ในกรอบของ 
Dependent List 

เลือกตวัแปรตนที่มีมากกวา 2 กลุมขึ้นไป แลว
คลิก ในกรอบ Factor 

 

 

เลือก Polynomial และคลิก Continue 
จากนั้นคลิก Post Hoc… 

 

 

เลือก Scheffe และคลิก Continue 
จากนั้นคลิก Options… 
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เลือก Descriptive และคลกิ Continue 
จากนั้นคลิก OK จะไดผลลพัธในหนาตางตอไปน้ี 

 
 การทดสอบคา F จะปรากฏตาราง 3 ตาราง ไดแก 1) Descriptive   2) ANOVA  และ 3) 
Multiple Comparisons ดังภาพ 
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พิจารณาที่คา Sig.ของคา F ถา > .05 สรุปวามี
ความคิดเห็นแตกตางกันระหวางกลุม ใหพิจารณา
คาในตาราง Multiple Comparisons ตอไป 

 

 

ถาคาเฉลีย่ของประชากรแตกตาง
กันจะมีเครื่องหมาย * อยูเหนือ
ตัวเลขในคา M.D. 

กรณีน้ีคาระดับนัยสําคัญที่ระดับ .05 พบ
ความแตกตางกันของคาเฉลี่ยจํานวน 2 คู 
คือ ผูบริหารกับหัวหนางาน และ หัวหนา
งานกับพนักงาน สวนผูบริหารกับพนักงาน
ไมพบความแตกตางกัน  
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ตารางเปรียบเทียบรายคูของตัวแปรจากการทดสอบคา F 
 
 ผูบริหาร (X1) หัวหนางาน (X2) พนักงาน (X3) 

ผูบริหาร (X1) 0 -2.00∗

P = .04 
-.40 

P = .785 

หัวหนางาน (X2) 
2.00∗ 

P = .04 
0 1.60∗

P = .04 

พนักงาน (X3) 
.40 

P = .785 
-1.60∗ 

P = .04 
0 

 
 สรุปไดวา มีความแตกตางกันของคาเฉลีย่ 2 คู ไดแก X1 กับ  X2  และ X2 กับ X3 ซ่ึงมีคาเฉลี่ย
แตกตางกันอยางมีนัยสําคัญทางสถิตทิี่ระดับ .05 หรือ p ≤ .05  สวน X1 กับ X3 ไมมีความแตกตางกันที่
ระดับนัยสําคญัทางสถิตทิี่ระดับ .05 หรือ p ≥ .05 
 
 4. การวิเคราะหคาสหสัมพันธ (Correlation Analysis) 
 สัมประสิทธิส์หสัมพันธ (r) เปนมาตรวดัระดับความเกี่ยวของหรือความสัมพันธกัน r มีคาอยู
ระหวาง -1…..ถึง…..+1  
 ถา X, Y มีคาเพิ่มขึ้นหรือลดลงไปในทศิทางเดียวกันแลว  r จะมีคาเปน + (บวก) 
 ถา X, Y มีคาเพิ่มขึ้นหรือลดลงไปในทศิทางตรงกันขามแลว r จะมีคาเปน – (ลบ)  
 ในที่น้ีจะนําเสนอการวิเคราะหคาสหสัมพันธแบบโมเมนต เพียงวธิเีดียวเนื่องจากเปนคาสถติทิี่
นิยมใชกันมากที่สุด  โดยใหดําเนินการตามขั้นตอนดังภาพ 
 

 

Analyze > Correlate > Bivariate 
แลวคลิกจะเปดหนาตางดังภาพตอไป 
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เลือกตวัแปรที่ตองการวิเคราะหคา r 
แลวคลิก ตวัแปรจะยายเขามาอยู
ใน Variables แลวเลือก Pearson 
และคลิก Option เพ่ือเลือกคาสถิติ
ดังภาพ 

 

 

เลือกคา Means and standard 
deviations และคลิก Continue 
จากนั้นคลิก OK จะไดหนาตาง
แสดงผลลัพธ ดังภาพ 

 

 

ตัวแปรที่ตองการศึกษา
ความสัมพันธ 

การพิจารณาวาตวัแปรคูใดมีความสัมพันธทางใดใหดู
ที่คา Sig.(2-tailed) ถามีคาต่ํากวาคา Alpha คือ นอย
กวา .05 สรุปวามีความสัมพันธกันอยางมีนัยสําคัญ
ทางสถิตทิี่ระดับ .05 และใหสังเกตคา r จะมี
เครื่องหมาย * ปรากฏอยู กรณีน้ีเรียกวา ขอ3_a มี
ความสัมพันธทางบวกกบัขอ3_b (คา r เปนบวก) 
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 5. การหาคาความเชื่อมั่นของเคร่ืองมือ (Reliability Analysis) 
  การหาคุณภาพของเครื่องมือดานความเชือ่ม่ัน  เปนขั้นตอนหนึ่งที่จะทําใหม่ันใจไดวา
เครื่องมือสําหรับการวิจัยน้ันสามารถใหคะแนนไดอยางม่ันใจไดวาไมคลาดเคลื่อน  โดยปกติการหา
คุณภาพดานความเชื่อม่ันของเครื่องมือน้ันมีอยู 3 วิธ ีคือ 1) การทดสอบซ้ํา (test – retest)  2) แบบแบง
ครึ่ง (split – half method หรือ odd – even method) และ 3) แบบวธิีของคูเดอร ริชารดสัน (Kuder – 
Richardson) ในการหาคาความเชื่อม่ันของเครื่องมือที่เปนแบบสอบถามที่มีลักษณะเปนแบบประมาณคา 
5 ระดับ น้ันจะใชวธิีของครอนบาค (Cronbach) ซ่ึงเปนการปรับปรุงมาจากวธิีของคูเดอร ริชารดสัน 
เรียกวา สัมประสิทธิ์แอลฟา (Alpha Coefficient) ในกรณีน้ีจะนําเสนอการวิเคราะหคาความเชื่อม่ันจาก
แบบสอบถามที่มีลักษณะเปนแบบประมาณคา 5 ระดับ โดยใชวธิีของ ครอนบาค (Cronbach) เทานั้น 
โดยดําเนินการตามลําดับขัน้ดังน้ี 

 

Analyze > Scale > Reliability Analysis… 
คลิกจะไดหนาตางดังภาพตอไป 

 

 

เลือกขอคําถามที่ตองการ
คํานวณแลวคลิก ขอคําถาม
จะเขามาอยูในกรอบ Items 
และเลือก Model ของการ
คํานวณคา กรณีน้ีเลือก Model 
เปน Alpha จากนั้นเลือก 
Statistics ดังภาพตอไป 
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เลือก Item, Means และ 
Correlations คลิก Continue และ
คลิก OK จะไดผลลัพธดังภาพ 

 

 

คาสัมประสิทธิ์แอลฟาจะมีคาอยูระหวาง 0 – 1.00 
คาความเชื่อม่ันใกล 1 มากเทาไรหมายความวา
แบบสอบถามชุดนั้นมีความเชื่อม่ันสูง แตถาคา
ความเชื่อม่ันอยูใกล 0 สรปุวาแบบสอบถามนั้นไม
มีความเชื่อม่ัน 
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